I am trying to retrieve data(aura components,apex classes) from salesforce nonscratch org(developer org). First I created the project, It worked fine then I authorized org that too worked fine but when Retrieve command is executed - its throwing error "ERROR running force:source:retrieve: Cannot read property 'record' of undefined". Please help.

  • Standard things here: Have you tried sfdx update? Have you checked the logs with tail ~/.sfdx/sfdx.log for errors? What errors do you see?
    – sfdcfox
    Commented Aug 23, 2020 at 20:07

2 Answers 2


Same here but being in the mac/unix realm the workaround didn't work for me. So my only solution so far is to downgrade the sfdx cli core pluggin :

sfdx plugins:install [email protected]

Replacing the current [email protected] as the log ({HOME_DIR}/.sfdx/sfdx.log) showed me that sfdx-cli is looking for a project definition file ({HOME_DIR}/.sfdx/sfdx-project.json) at the {HOME_DIR} level, disregarding the current project config files. Idem for the previous versions (49.6.1).

Also note that that the issue has just reached the forcedotcom/cli team. I presume we now wait for a resolution in the next updates.

  • Thank you Eric S. I just did "sfdx plugins:install [email protected]" and it's working now. Thx.
    – Andonon
    Commented Sep 26, 2020 at 1:25

Same is happening to me.

When I right click package.xml --> "SFDX: Retrieve Source in Manifest from Org" I get the same error: "ERROR running force:source:retrieve: Cannot read property 'record' of undefined".

I'm using version "sfdx-cli/7.71.0-4193fb4acc win32-x64 node-v12.18.3"

As a workaround, you can execute the command in the terminal tab

sfdx force:source:retrieve --manifest "drive\:path_to_manifest\package.xml" 

(Note the double quotes). Everything else seems to be working.

I'm unsure if this is a bug with the VS Salesforce Extension or Salesforce CLI.

  • Same here w/latest sfdx version as of 2/2/22 ... very annoying! Commented Feb 22, 2022 at 15:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .