1

enter image description here We are implamenting a chatbot using the OAuth 2.0 JWT Bearer Token Flow and see the above errors in the browser client degugger. We already have a valid access token and the origin has already been white-listed in SalesForce. Has anyone else ran across these errors?

8
  • When I look at the response to GET /2020myBCUKnowledge/embeddedService/sidebarApp.app?aura.format=JSON&aura.formatAdapter=LIGHTNING_OUT HTTP/1.1 using Fiddler I see there is actually an decode response "*/{"message":"An internal server error has occurred\nError ID: 628246039-202345 (924250524)"}/*ERROR*/" . With a little googling I've found this is known to Salesforce Support as a "Gack". Any idea what the particular code I received means? – M. Brandel Aug 23 '20 at 4:20
  • My assumption is the Gack error is preventing the full responce from being generated so the Access-Control-Allow-Origin header is never returned on the responce. Is this a valid assumption? – M. Brandel Aug 24 '20 at 23:08
  • I suggest that you raise a support case so support can investigate it. – Mohith Shrivastava Aug 24 '20 at 23:31
  • Also, more details with code will help to debug it further – Mohith Shrivastava Aug 24 '20 at 23:31
  • 1
    We have this issue resolved. It was one of the Orgwide settings that needed to be enabled - Setup > Security > Session Settings - Activate the Lock sessions to the IP address from which they originated check box. – M. Brandel Aug 27 '20 at 17:20
1

To Summerize what fixed this issue for us:

  • We added the Integration User to the Site (Community).
  • Selected the Orgwide session setting - Setup > Security > Session Settings - "Activate the Lock sessions to the IP address from which they originated"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.