0

We have a new sandbox and are logging in as a System Admin user. The Org Wide Default sharing settings on Accounts (and most objects) is Public Read Write. System Admin permissions on Account are View All. However, when I run a simple query such as

Select Id, Name from Account

I get no results. I thought perhaps no data was imported, so I decided to create my own via the UI. When I started typing in names for the Accounts - the Account names from production started showing up! When I select one, it fills all the information for the account. Does anyone have any idea what could be going on here?

Update: This is a developer sandbox (which I didn't know), so it is not supposed to have data. I guess the question becomes how we see the data that comes up as we input Account names?

I ran the query using the Salesforce inspector.

  • What happens when you run this query? : SELECT HasReadAccess, HasEditAccess, MaxAccessLevel FROM UserRecordAccess where UserId = 'System Admin's user ID' and RecordId = 'Account Record ID returned from the UI' – Anudeep Gopagoni Aug 16 at 18:25
  • Please edit your post to include more details. What tool are you using to execute the query? What happens when you query other objects like Contacts etc? How did you import data into the sandbox? – David Cheng Aug 16 at 20:21
  • 1
    Sounds like you have a browser extension that auto-fills forms with data that you've saved in the browser. – David Cheng Aug 17 at 23:40
  • @DavidCheng this is data from an org that I never logged into! I don't have credentials for the prod org! – hgolov Aug 23 at 17:18
0

Thank you all for your comments. I guess it really doesn't matter what's going on with the autocomplete, and since I realized that the sandbox was created without data, I'm going to close out this question.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.