3

When trying to authorize an org/ trying to deploying source to org / retrieve the source from an org i'm getting below error. kindly help me to resolve this issue. enter image description here

3
  • 1
    Have you tried updating sfdx? Run sfdx update from command prompt or terminal, and try again.
    – Raul
    Aug 16, 2020 at 9:49
  • I have experienced the same issue in the past. Reinstalling the SFDX CLI has resolved the issue for me SFDX CLI installation link: developer.salesforce.com/docs/atlas.en-us.sfdx_setup.meta/… Aug 16, 2020 at 18:34
  • Thank you all for your reply. I tried both updating CLI using SFDX update command and reinstalling salesforce CLI in my machine. Both workarounds don't work for me. Aug 17, 2020 at 2:48

3 Answers 3

7

run the command sfdx plugins:uninstall salesforcedx in cmd prompt terminal,this will resolve your issue

1
  • This helped but can you explain what's the possible cause please ? Sep 4, 2020 at 10:12
2

I had the same problem and I solved it following the steps of this link: https://developer.salesforce.com/docs/atlas.en-us.sfdx_setup.meta/sfdx_setup/sfdx_setup_uninstall.htm

Hope this solve your problem.

P.D: The steps to solve it: Select Start > Control Panel > Programs > Programs and Features.

Select SFDX CLI, and click Uninstall.

Inside your home directory, delete the .config\sfdx directory.

3
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review Aug 17, 2020 at 10:46
  • Sorry, I edit my answer. Thanks for the advice :D Aug 17, 2020 at 10:55
  • Thanks to everyone.By executing sfdx plugins:uninstall salesforcedx in cmd prompt resolved the issue. Aug 19, 2020 at 6:25
0

1- Uninstall Salesforce CLI

2- Go to windows explorer and use this path "%LOCALAPPDATA%\sfdx"

3- Delete all the files from there

4- Reinstall Salesforce CLI

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .