2

I cannot figure out what is going on that is causing my debug logs to not show up when using the "SFDX get debug logs" command palette command and it is driving me nuts. I'm spending more time on configuration lately then coding. I turn on "Turn on Apex Debug Log for Replay Debugging", execute a test and then run "get apex debug logs"

get apex debug log results

The last debug logs it gets are from 3:30AM, and they are from developers that are not myself. However if i run the query Select Id, StartTime, Operation FROM ApexLog WHERE LogUserId = '0052i000000oUnLAAU' I find plenty of logs that i've created from 11AM this morning on. Why is the get apex debug logs command not returning them, i'm at a loss

Apex log query

I do have User_debug log level on as well (Every setting is as fine as possible) and i can retrieve logs with sfdx force:apex:log:get but i can't use Apex replay debugging with those returned logs and its also more time consuming. Any thoughts? Also what is the exact difference between a DEVELOPER_LOG and USER_DEBUG log? if i modify a record that subsequently runs an apex trigger and only have a DEVELOPER_LOG on, will it record a debug log? What exactly will a DEVELOPER_LOG record that a USER_DEBUG log won't?

2
  • Have you been able to figure it out? I have the same issue. – jojopogi Nov 6 '20 at 20:29
  • unfortunately not – Bobbygllh Nov 13 '20 at 19:47
0

Deleting the logs from the org worked for me. I ran these commands in the terminal and it worked.

sfdx force:data:soql:query -q "SELECT Id FROM ApexLog" -r "csv" | out-file -encoding utf8 out.csv sfdx force:data:bulk:delete -s ApexLog -f out.csv

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.