1

I have run into an issue where if I am unchecking a checkbox: 'Let guest users see other members of this community' under general setting in Preferences. If the check box is checked, welcome emails are getting triggered. We unchecked it due to some security issues. But I am not sure what is the relation between this and sending email.

We send the welcome emails using standard "Welcome New Member" functionality of communities.

Do Anyone know whats wrong here.

enter image description here

1
  • we are having a similar issue. Did you found a solution for this ?
    – Shamina
    Jan 19 at 14:49

2 Answers 2

2

You need to select "Send Welcome Email" on Emails Menu

enter image description here

Please, take into account the following:

Salesforce sends welcome emails when:

  • A community changes from Preview status to Active status. An inactive community doesn’t receive emails unless the associated org has a default portal or if the user’s profile is part of an active portal.
  • An admin adds a profile or permission set to an active community.
  • A user of an active community is assigned a profile or permission set.

read more about it here

1
  • 1
    I had checked this checkbox. But still issue was there. We have raised this with salesforce. Will post If we get some answer. The issue reproduces on sandboxes only and not on production. Also only if, if I am unchecking a checkbox: 'Let guest users see other members of this community' under general setting in Preferences the issue occurs else it works perfectly fine. Oct 9, 2020 at 8:24
0

Make sure you activate the community.

Administration > Settings > Activate

1
  • 2
    Hi Sébastien, welcome to SFSE. Please take a moment to scroll through the tour and read How to Ask and How to Answer if you haven't already. Just a heads up, if you put questions in your Answer posts, they will often get flagged as low quality, even if your answer in and of itself is perfectly valid.
    – Adrian Larson
    Aug 19, 2021 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.