0

I'm trying to send an email created in content builder using email send flow to sf report.

The sf report is located in an org which is connected to the relevent BU this send is initiated from. I can see the report name and can select it as part of selecting the audience for sending the email.

However once the final send button is clicked this general error appears:

There was an error sending this email

We have double checked the mc api user and salesforce system user are configured correctly.

Please keep in mind the relvent mc user that tries to send the email is not the mc api user. If we login with mc api user the email is sent successfully.

Please advise what we should do in order for this to work for the relevent mc user?

Thanks,

Barak

7
  • Check if the user who is trying to send it is mapped with his SF user. In SFMC go to Users > click on username > Integration - if it says ‘not integrated’, click on Integrate and type in user’s SF username
    – zuzannamj
    Commented Aug 14, 2020 at 9:04
  • Hi zuzannamj, thanks I will check that out. Are there any settings/permissions that needed to be configured to the sf user who is mapped to this mc user (the one trying to send the email)? Or mapping it to the relvent mc user should be enough? I ask this beacuse I remeber that the salesforce system user who is mapped to our mc api user needed to be granted certain permissions. Are those premissions in sf should be applied to any sf user mapped to mc user - or just the salesforce system user needs them? Thanks again
    – Barak
    Commented Aug 14, 2020 at 12:53
  • 1
    Yes, that person needs at least the permissions of the ‘Marketing Cloud Connect User’ - take a look here: help.salesforce.com/…
    – zuzannamj
    Commented Aug 14, 2020 at 18:47
  • Thanks zuzannamj. Regarding this line in the documentation: "Access to Marketing Cloud Connect functionality in the Marketing Cloud is managed through Marketing Cloud Connect permissions." Any idea how to get to the marketing cloud connect premissions that is mentioned here? Thanks again.
    – Barak
    Commented Aug 14, 2020 at 21:07
  • 1
    Make sure the user has `Marketing Cloud for AppExchange User’ checkbox checked and has the Marketing Cloud Connected App permission set
    – zuzannamj
    Commented Aug 15, 2020 at 16:09

1 Answer 1

2

In order to be able to send emails using Marketing Cloud Connect, a user needs to have access to both clouds, access to Marketing Cloud Connect in the Salesforce org and needs to be mapped correctly in Marketing Cloud.

Follow these steps to complete the setup:

  1. In Sales/Service Cloud, navigate to Users and edit the user who is trying to perform the send. Make sure that on the User, the Marketing Cloud for AppExchange User checkbox is checked and that the user has the Marketing Cloud Connected App permission set assigned
  2. In Marketing Cloud, navigate to Users and click on the username of the user who is trying to perform the send. Under Salesforce.com Status click on Integrate and paste the user's Salesforce org username. Save.

Now the User should be able to send to Salesforce Reports and Campaigns.

Source: https://trailhead.salesforce.com/en/content/learn/modules/marketing-cloud-connect/finish-mc-connect-configuration

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .