0

I experience problem with high CPU usage after every start of visual studio code. It is strictly related to apex extension. It started happening when some pop up appeared in bottom right corner. I think it was something with objects (not sure). After clicking "enable" button, some sfdx process started running and after that, everytime i start vscode there is zulu platform x64 architecture proccess that takes my cpu to the limits. Ending task helps, but then I don't have some sfdx functionalities like running tests. "Run Test" label is missing:

enter image description here

I can end task in manager which stops the problem but then I'm not able to run tests (option is missing) from vs code. I tried to wait for the proccess to finish but it seems nothing else happens. After ending task it takes like 15 minutes and this proccess starts to take more and more cpu usage until its max.

What are your recommendations? I tried to wait for this proccess to end as I thought that maybe it's indexing objects or smth but after 1 hour it was still working the same.

I also raised a bug about it on github page https://github.com/forcedotcom/salesforcedx-vscode/issues/2410

Task manager

2