1

We have embedded service chat and with the update to Chrome 84, some cookies are being blocked. I'm not sure if this has an impact on the actual chat, but it worries me. I see the following error in the Chrome Console:

A cookie associated with a cross-site resource at https://d.la3-c1cs-ph2.salesforceliveagent.com/ was set without the SameSite attribute. It has been blocked

Can I do anything on my end to configure Salesforce or change something on the page? Or is it up to Salesforce to change how their cookies work?

1
1

we are having the same error since Chrome 84 has rolled out, you can mimic the cookie policy by accessing your site incognito or switching cookie policy to strict in settings (which will be done by default for all Chrome users).

Just commenting to let you know I've started a case with Salesforce for this exact reason, Salesforce should be setting their cookie policy and sending it with their reply when our site requests this, there are no settings I'm aware of (have searched high and low) to set these.

Could you raise a case also and link this my case number 27142199 if you'd like to see this is happening to multiple people.

Regards, Ryan

1
  • Hi Sander, I have answered the question with "Salesforce should be setting their cookie policy and sending it with their reply when our site requests this, there are no settings I'm aware of (have searched high and low) to set these." and included further that i've ultimately had to raise a case as this is a Salesforce issue to set samesite settings in their cookies. Thanks – Ryan Aug 13 '20 at 9:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.