3

Did anyone had faced this issue? Is there a solution?

I'm not sure if this is a bug or what else can I do to view the code coverage in a Package Org (Classic Managed Package).

When I try to run all the tests in a Managed Package org I see the error "Code coverage from running this test class was not applied due to a conflicting recompilation task running at the same time" in many tests even after recompiling all apex classes.

3
  • Have you tried running the tests again, at a time when there isn't a re-compilation taking place?
    – Derek F
    Jul 28, 2020 at 11:14
  • Yes, tried again. It seems that only worked if I run them separately, which makes me feel this is a bug. Jul 28, 2020 at 12:19
  • 1
    @JefersonChaves Please update here if you find any resolution. I am also facing the same issue. thanks. Feb 8, 2021 at 12:07

1 Answer 1

1

It is happening because of conflicts coming from parallel execution of multiple test runs. You can try disabling the 'Parallel Apex Testing' setting under Apex Test Execution settings.

Steps to follow: Setup | Apex Test Execution | Option | Disable Parallel Apex Testing - True

2
  • Thanks Mahesh, the package org I tried this, as far as I recall had parallel testing disabled. Did this solved the problem for you? Feb 9, 2021 at 15:53
  • 2
    Yes Jef, it did. Feb 11, 2021 at 5:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .