0

I build CI/CD pipeline in Azure Pipelines and I call force:auth:jwt:grant to authenticate a sandbox. It fails with ERROR running force:auth:jwt:grant: Failed to decipher auth data. reason: Unsupported state or unable to authenticate data.

In the pipeline I call the following command (the same I call from my local machine): sfdx force:auth:jwt:grant --clientid 3MVG9uXXXX --jwtkeyfile XXX\server.key --username yay-dXXX -r https://test.salesforce.com

OBS! force:auth:jwt:grant worked the very first time I run the pipeline. Every run of the pipeline after that ended with the above-mentioned error.

OBS! It works successfully every time when I call the same command from my local machine:on my local machine

I also call force:auth:list to get more details. It has the same error in the Error column enter image description here

I can not logout from the org (force:auth:logout --all -p). It fails with the same error.

Checked the accessibility of the server.key in the Azure pipelines. It is accessible as I can see:

enter image description here

Any ideas where the reason is hidden?

Checked the other open related questions here, but none of them helped. Again, the authentication is successful from my local machine, and when I tried to authenticate from the Azure pipeline the very first time it was successful, but it was only the first time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.