0

I have a custom lightning page that is set as the default for all users. However, the flow that is supposed to appear does not appear for the users.

  • They have permission to run flows.
  • It does show up for system administrators
  • It updates a field on the record that the custom page points to

Also, the flow does update a field. Must the user have permission to edit that field for the flow to work?

  • 1
    Yes. The field must be accessible to the users. If the field is hidden, it would impact the component visibility . Related:trailblazers.salesforce.com/answers?id=9063A000000a21FQAQ – Swetha Jul 16 at 14:25
  • No luck on that. I am using an external service in the flow as well as named credentials for the external service. Does that matter? – jle Jul 16 at 18:44
0

It turns out that the way I had to solve this was by unchecking a box. There is a little arrow next to the flow with a dropdown to 'edit access'.

The SF docs say that:

Control user permission to run flows via:

The “Manage Flows” permission The "Run Flows" permission The Flow User field on their user detail page If Override default behavior and restrict access to enabled profiles or permission sets is selected for an individual flow, access to that flow is given to users by profile or permission set

I had the 'override' checked so it was not using the normal behavior. As soon as I unchecked the box everything worked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.