0

I've been able to implement a current Salesforce project using Visual Studio Code as practice for implementing Salesforce DX. But suddenly, all sfdx commands (sfdx:authorize an org, sfdx: create a project, etc.) suddenly stopped working.

Following is one of the error it displays each time I access recently used commands:

enter image description here

I uninstalled and re-installed both Salesforce CLI and Visual Studio Code on my device but it still displays same error. I even uninstalled and reinstalled Salesforce Extension Pack just to make sure, but still doesn't work. Also, I noticed that it is not even initializing on the lower left part and does not display any problems.

Below are the versions of Salesforce CLI and Visual Studio Code currently installed on my device:

Visual Studio Code 1.47.1

Salesforce CLI sfdx-cli/7.65.4-c99e705754 win32-x64 node-v12.13.0

Hoping someone could help me on this.

2
  • 1
    Sometimes, closing VSCode and re-starting it helps. Other than that, did you perhaps recently update/upgrade your java runtime?
    – Derek F
    Commented Jul 15, 2020 at 18:39
  • @DerekF I haven't tried any updates/upgrades for java runtime. Tried also multiple restarts on my end but still doesn't work. Encountered this previously and restart did work. But not this time :(
    – Ertyq
    Commented Jul 15, 2020 at 19:16

1 Answer 1

0

I get the same issues here, to solve it on my MAC I follow these steps:

  1. Access the folder ~/.local/share
  2. deleted the folder sfdx using the command rm -rf sfdx
  3. Downloaded the last version on https://developer.salesforce.com/tools/sfdxcli and reinstall

After that, it backs to work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .