0

I am trying to add the HelpText in to the VF Page and I tried few options like below and none of them is working for me. Added the HelpText in the <apex:pageblockSectionItem>

<apex:pageblockSectionItem helpText = "Test">
   <apex:outputPanel >
      <div class="ListLevel02">
         <apex:outputLabel value="Type 1" ></apex:outputLabel>
      </div> 
   </apex:outputPanel>
   <apex:inputcheckbox value="{!conRec.Type_I__c}" styleClass="ListLevel02"></apex:inputcheckbox>
  </apex:pageblockSectionItem>   

enter image description here

HelpText is not enabled and cant click on them. I tried to have the HelpText added at the field

enter image description here

And tried using them like

 <apex:pageblockSectionItem helpText= "{!$ObjectType.Contact.Fields.Type_I__c.inlineHelpText}">

Even this has the same behaviour. Can anyone say what am I missing here

3
  • I think Visualforce attributes are case-sensitive, so try helpText. Also you should use double-quotes and not single quotes for your pageBlockSectionItem example. Also "HelpText" is not a valid attribute for apex:outputLabel be sure to check the Visualforce documentation – David Cheng Jul 14 '20 at 0:12
  • @DavidCheng Sorry that was atypo I added the helpText to the apex:pageblockSectionItem and I have double quotes around the String and I tried both helpText as well as the HelpText but I just see a ? but they are disabled as shown in the image – user81642 Jul 14 '20 at 0:35
  • @DavidCheng I updated the question with the updates you mentioned but still not working I just see the disabled ?. Is there something to do with the lightning lightningStylesheets enabled on the VF – user81642 Jul 14 '20 at 0:41
0

Try this : (SVG icon might not be visible as this is for my local machine but you can add your own image to make it work)

<apex:outputPanel>
    <apex:outputText style="font-weight:bold;font-size:smaller;" value="{!$ObjectType.Contact.Fields.Type_I__c.label}" />
    <span class="popover" id="netNewEngagement">
        <div>
            <div class="slds-form-element__icon slds-align-middle">
                <span class="slds-popover-button slds-button slds-button--icon coolGreyIcon">
                    <c:svgIcon styleClass="slds-icon slds-icon-text-default slds-icon_xx-small coolGreyIcon" iconLocation="/assets/icons/utility-sprite/svg/symbols.svg#info_alt"
                               isSLDS="true" />
                </span>
            </div>
            <div class="slds-popover slds-nubbin--left" role="tooltip">
                <div class="slds-popover__body slds-cell-wrap">
                    <apex:outputText value="{!$ObjectType.Contact.Fields.Type_I__c.InlineHelpText}" escape="false" />
                </div>
            </div>
        </div>
    </span>
</apex:outputPanel>
3
  • Sorry I am not able to follow. Can you please tell me what is missing in my code why should we be creating the icons – user81642 Jul 14 '20 at 0:43
  • I get error saying Component c:svgicon does not exist – user81642 Jul 14 '20 at 0:50
  • insert any image in static resource and use it in place of c:svgicon – C0DEPirate Jul 14 '20 at 21:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.