0

I have created a custom domain site. We have found security Vulnerabilities in the cookies of Salesforce. Description: 1. BrowserId cookies does not have samesite attribute set. 2. force-proxy-stream - Also found Vulnerability in this cookie. 3. force-stream - Also found Vulnerability in this cookie.

How can we set this cookie in Apex?

Please help me!

0

All cookies you can set in Apex are prefixed by "apex-". As such, you can't do anything about these cookies. It is a cookie used by Salesforce for first-party tracking and analytics.

2
  • Thanks, I am working on a banking project. Where security is the main concern. Is there any other way to overcome from these issues?
    – SFDC 44
    Jul 10 '20 at 4:32
  • @RAHULSRIVASTAVA These cookies are used across multiple Salesforce domains, so they can't be samesite or they'd lose their functionality. You may want to contact Salesforce Support about this, but I'm pretty sure these cookies are useless to anyone outside of Salesforce.
    – sfdcfox
    Jul 10 '20 at 12:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.