0

Even when I untick the "Trigger workflow rules and processes for new and updated records" in Import wizard, I still get this error:

CANNOT_INSERT_UPDATE_ACTIVATE_ENTITY:CE_InputTrigger: System.LimitException: Too many SOQL queries: 101:--

Why does it still happen? How do I make it bypass the trigger?

Data import wizard

  • If this is just a straight insert of records of a specific SObject type, then this is something of a indicator of non-bulkified code, SOQL in a for loop or similar which needs addressing as well. That aside, this setting won't affect the Apex trigger. Crudely, you could manually deactivate the trigger for the import then reactivate it afterwards, but I suspect that there's a scalability issue here as well. – barrick Jul 9 at 9:05
  • @barrick But then what is the use of the checkbox "Trigger workflow rules and processes for new and updated records" if I need to manually deactivate the trigger? – compski Jul 10 at 10:19
  • it lets you choose whether the workflow rules and processes are invoked for the records, not the triggers themselves. – barrick Jul 10 at 10:37
2

It looks like an issue with the Trigger Code, it can be a code quality issue (SOQL Query in a loop, excessive use of SOQL, etc. ).

I think that you can still load your data but a code review should be done to bulkify the triggers code.

If the Business logic implemented in the trigger (on that object you're loading) can be bypassed, you can deactivate the trigger by unchecking the "active" checkbox. This is cannot be done directly in the Production environment.

Either by deployment: Redeploy Triggers with unchecked Active checkbox OR by Implementing a bypass mechanism in Apex

Another easy approach is to reduce the batch size in Data Loader to a low value where the limit issue is not encountered (I know it will take an eternity to load you but can try decreasing the batch size gradually 50 then 20 then 10 or even 1 - loading 1 by 1 will be really long).

| improve this answer | |
  • Yes I want to bypass my triggers via use of the checkbox "Trigger workflow rules and processes for new and updated records" in import wizard. How come it is not working? – compski Jul 10 at 10:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.