0

Just to give a background. We have bought SAP with a sub-domain and haven't yet purchased SSL for that sub-domain.

Am getting an intermittent error saying 'Your connection is not Private Error' for some customers and in different browsers when a customer clicks on the Marketing cloud links in email, it is re-directing to http://click.SAPdomain.com .

But for other customers it is working fine.

Below is the screenshot for the same.

enter image description here

Have anyone this issue before? We can buy a SSL for SAP but it takes sometime. Is there any workaround for it?

Thanks for your help in advance!

2 Answers 2

3

It looks like your web server at your root domain is emitting an HSTS header requiring subdomains to also serve pages using TLS. SFMC's web servers hosting your click-through pages etc respect this standard and are serving pages over SSL. You have not purchased (and eventually implemented) SSL Certificates with Salesforce, so the servers will be using ExactTarget/MarketingCloud certificates.

Purchasing and installing certs for SFMC is a slow process and you can expect it all to take four or five weeks, for some reason. As a quick fix, if you relaxed the HSTS policy on your root domain's web servers, you should see the issue disappear and then you could re-enforce HSTS when the SFMC certs are installed. Alternatively, you could possibly engage SFMC support to cease serving of your links using your SAP subdomain for a while, until certs for the SAP subdomain are online.

1
  • Thank you so much Mecca for your answer!. I will check with my IT team and post the update.
    – Naveen VM
    Commented Jul 9, 2020 at 10:50
1

Answering to my own question.

Root Cause: IT Team have enabled the root/main domain on HSTS. Which means only Https redirection is only possible to the main domain. Since our initial SAP domain is without SSL so it will not be Https. That is the reason it is throwing out an error.

To Check whether your IT team has enabled HSTS or not, You can go to this URL - https://xnnd.com/hsts.cgi and enter you main domain. It would say whether HSTS is enabled or not.

Solution:

You can work with either of below 2 solutions:

  1. Either buy a SSL for SAP (You would need to purchase separately from SFMC and it will take 4-5 weeks of time).
  2. Ask the IT Team to disable the HSTS from the root domain.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .