0

Case owner not displaying in case view but Owner Name is fine in List View. Case Owner not visible

Customer Service user is able to create the case for Street Scene successfully and view it once complete but not the Case Owner field. If you click on the _ you get an 'Insufficient Privileges' error. A workflow assigns the Case Owner to the Street Scene Queue and the field is Read Only on the that case layout. Our cases are Private and there are sharing rules in place to allow members of the customer services group read only access to the Cases owned by the Street Scene Queue. As the user can still view the case then the sharing rule is working but I haven't been able to figure out what is preventing them from seeing the Case Owner. If I add the user to the Street Scene queue that fixes the problem but we don't want them in the queue. The setup is currently working as required in Production and it's UAT for the latest release testing that I've found the issue although it looks to be only minor. Any ideas on what permissions are missing for this field as I've compared to production and I can't spot any differences. Thanks in advance for any suggestions, fingers are crossed it's something simple I've overlooked! They are still in Classic, could this be the issue?

I've since established that once the case is picked up and assigned to a user in Street Scene, this field is then populated even though permissions is again applied by a sharing rule to a public group to be read only so the problem seems to be when its a Queue and in Classic as in Lightning its ok.

0

In Salesforce Classic, users who don’t have Read access or the View All Lookup Record Names permission see an underscore in system user lookup fields. They also see the record ID in custom user lookup and non-user lookup fields.

After the Require permission to view record names in lookup fields setting is enabled, in Lightning Experience, users who don’t have Read access or the View All Lookup Record Names permission see the lookup field labels, but not the data in the fields.

You should go an check the following in your OWD Sharing settings "Require the View All Lookup Record Names Permission"

https://help.salesforce.com/articleView?id=release-notes.rn_forcecom_general_lookup_setting.htm&type=5&release=230

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.