0

I configured a Salesforce external data source to connect to my Office 365 online Sharepoint account. Everything worked! I was able to browse Sharepoint files from the Files tab.

I go to grab some lunch, come home and log back into my computer, and now Sharepoint is giving me the "EXTERNAL OBJECT EXCEPTION" error. I tried changing the Salesforce auth provider authorize endpoint prompt parameter from "consent" to "login" and tried changing the scope on the external data source from blank to "Files.ReadWrite.All Sites.ReadWrite.All User.ReadWrite.All". I've also tried deleting everything on Salesforce and Azure but no luck there. Nothing works.

I'm thinking this is an error on Salesforce servers since things all of a sudden stopped working.

I see the scope in the Azure audit logs saying the OAuth request is only asking for "User.read" - shouldn't that be all the permissions needed for the external object even though Salesforce files connect directions say leave the scope field blank?

Thanks in advance!

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

0

I figured this one out to be a permissions issue in Azure. Even though I'm using "named principal" on Salesforce I had to add all the Sharepoint delegated permissions on Azure.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.