0

Component name is mycmp.

mycmp.html:

<template>
   dfdsdf
</template>

mycmp.js:

import { LightningElement } from 'lwc';
    
export default class Mycmp extends LightningElement {}

mycmp.js-meta.xml:

<?xml version="1.0" encoding="UTF-8"?>
<LightningComponentBundle xmlns="http://soap.sforce.com/2006/04/metadata">
  <apiVersion>45.0</apiVersion>
  <isExposed>true</isExposed>
  <masterLabel>mycmp lbl</masterLabel>
  <targets>
    <target>lightning__AppPage</target>
    <target>lightning__RecordPage</target>
    <target>lightning__HomePage</target>
  </targets>
</LightningComponentBundle>

I have deployed the component to my developer org. But it is missing in App Builder for App Page.

enter image description here

I have met the issue during completion of trailhead Use Lightning Data Service to Work with Data

Updated Jun 5, 2020: List of components from Setup -> Lightning Components: enter image description here

5
  • Did you follow the steps in Configure a Component for Lightning App Builder such as setting up My Domain?
    – Phil W
    Jul 4 '20 at 21:25
  • Domain is here. Probably not everything is deployed properly, or an API version of component is old - should be 48
    – kurunve
    Jul 4 '20 at 21:29
  • I have started from API version 48, the same behavior. I have also updated Saleforce DX plugin to the latest version. Jul 5 '20 at 4:53
  • Regarding verification if everything was deployed: Setup -> Lightning Components contains the component, last modification date was updated; I have tried to add the component to another LWC component and it was shown; SOQL query Select Id,Source,FilePath from LightningComponentResource from Tooling API returns the same code. Jul 5 '20 at 5:01
  • 1
    @PhilW yes, I followed the steps from Configure a Component for Lightning App Builder Jul 5 '20 at 6:25
0

Verify few things:-

masterLabel -- <masterLabel>mycmp lbl</masterLabel>

The title of the component. Appears in list views, like the list of Lightning Components in Setup, and in the Lightning App Builder and in Experience Builder.

I have seen your configuration file is having masterLabel tag, make sure your looking the name used there in App Builder. Though your component name is mycmp, component name in app page appear would be mycmp lbl

Also, check your all your lightning component in the org by following steps:-

  1. From setup, enter Lightning Component in the Quick Find box, then select Lightning Component.
  2. It will open a list of Component of both the type:- Aura and LWC

enter image description here

3
  • Hello Sanket, Thanks for the answer. As you can see on screenshot from my question, the component is missing in App Builder. It doesn't contain component with name 'mycmp lbl'. The component is present in Setup -> Lightning Components but is missing in App Builder. Jul 5 '20 at 6:02
  • I have updated my question with list of components from Setup -> Lightning Components. Jul 5 '20 at 6:16
  • I note that it is not listed with "mycmp lbl" in the screenshot you have provided. Please check that you have consistent details in your question.
    – Phil W
    Jul 5 '20 at 6:35
0

After multiple times redeployment with adding and removing new line character at the last line of the js-meta.xml file the component appeared in App Builder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.