I am still new to flows but I tried to re-create a flow listed here which would automatically add an account team member in a specific role to a case team. I know the issue isn't with my Process Builder since I simplified that but still no account team members are getting added to the case team.

I ran debug on my flow and the Fast Lookup and Loop seem to be working ok. Below are the results:

FAST LOOKUP: Find_Account_Team_Members Find all AccountTeamMember records where: AccountId Equals {!AccountIDfromPB} (001c000002UqYUWAA3) Team_Role_Custom__c Equals Client Service Director Store the values of these fields in Find_Account_Team_Members: Id Result Successfully found records.

LOOP: Loop_Through_Account_Team_Members End Loop.

FAST CREATE: Create_Case_Team_Members Create CaseTeamMember records using the values that are stored in {!CaseteamMembers}. Variable Values None. Result All records are ready to be created when the next screen, pause, or local action is executed or when the interview finishes.

How can I fix this so the case team member(s) populate? Below is a screenshot of the overall flow. Note that we are using a custom account team role field which I accounted for in the Get Records (lookup) element.

enter image description here

  • if the loop was working you would see debug for each iteration; be sure your loop is referencing the output of a record collection variable that is the result of the Get Records element
    – cropredy
    Jun 25, 2020 at 0:10
  • @cropredy thank you, I added that as shown here instead of setting it to "automatically store all fields": ibb.co/gmWm7ds. Jul 1, 2020 at 14:37
  • @cropredy But now I am getting an actual error: FAST CREATE: Create_Case_Team_Members Create CaseTeamMember records using the values that are stored in {!CaseteamMembers}. Variable Values [MemberId=005c0000006nKMBAA2,ParentId=500c000000HGwUFAA1,TeamRoleId=0B7c0000000Cdo] Result Failed to create records. Error Occurred: This error occurred when the flow tried to create records: MALFORMED_ID: Team Role ID: id value of incorrect type: 0B7c0000000Cdo. This is the ID of my Case Team role, I pulled it from the URL: [mydomain]/lightning/setup/CaseTeamRoles/page?address=%2F0B7c0000000CdoO Jul 1, 2020 at 14:38
  • @cropredy it seems like Flow is dropping the last "O" from my ID? Jul 1, 2020 at 14:42
  • (1) looks like a copy-paste error; (2) Flow should not use hard-coded Ids - query for the CaseTeamRole in the flow
    – cropredy
    Jul 1, 2020 at 16:09

1 Answer 1


Resolution was using the standard Account Team role field instead of a custom field created by our development team. In addition, needed to create a lookup to find the Case Team Role ID.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.