0

When I try to create project with manifest I am getting the following error:

 Starting SFDX: Create Project
> 
> 10:25:36.141 sfdx force:project:create --projectname AmDev
> --outputdir c:\Users\shruthim4\Documents\VS Code --template standard --manifest { AssertionError [ERR_ASSERTION]: Trying to copy from a source that does not exist: C:\Program Files
> (x86)\Sfdx\client\node_modules\salesforcedx-templates\lib\templates\project\standard\ScratchDef.json
>     at EditionInterface.exports.copy (C:\Program Files (x86)\Sfdx\client\node_modules\salesforcedx-templates\node_modules\mem-fs-editor\lib\actions\copy.js:49:3)
>     at EditionInterface.module.exports [as copyTpl] (C:\Program Files (x86)\Sfdx\client\node_modules\salesforcedx-templates\node_modules\mem-fs-editor\lib\actions\copy-tpl.js:29:8)
>     at ProjectGenerator.writing (C:\Program Files (x86)\Sfdx\client\node_modules\salesforcedx-templates\lib\generators\projectGenerator.js:57:17)
>     at Object.<anonymous> (C:\Program Files (x86)\Sfdx\client\node_modules\salesforcedx-templates\node_modules\yeoman-generator\lib\index.js:427:27)
>     at C:\Program Files (x86)\Sfdx\client\node_modules\run-async\index.js:25:25
>     at new Promise (<anonymous>)
>     at C:\Program Files (x86)\Sfdx\client\node_modules\run-async\index.js:24:19
>     at self.env.runLoop.add.completed (C:\Program Files (x86)\Sfdx\client\node_modules\salesforcedx-templates\node_modules\yeoman-generator\lib\index.js:428:13)
>     at runCallback (timers.js:705:18)
>     at tryOnImmediate (timers.js:676:5)   generatedMessage: false,   name: 'AssertionError [ERR_ASSERTION]',   code: 'ERR_ASSERTION',  
> actual: false,   expected: true,   operator: '==' } { AssertionError
> [ERR_ASSERTION]: Trying to copy from a source that does not exist:
> C:\Program Files
> (x86)\Sfdx\client\node_modules\salesforcedx-templates\lib\templates\project\standard\ScratchDef.json
>     at EditionInterface.exports.copy (C:\Program Files (x86)\Sfdx\client\node_modules\salesforcedx-templates\node_modules\mem-fs-editor\lib\actions\copy.js:49:3)
>     at EditionInterface.module.exports [as copyTpl] (C:\Program Files (x86)\Sfdx\client\node_modules\salesforcedx-templates\node_modules\mem-fs-editor\lib\actions\copy-tpl.js:29:8)
>     at ProjectGenerator.writing (C:\Program Files (x86)\Sfdx\client\node_modules\salesforcedx-templates\lib\generators\projectGenerator.js:57:17)
>     at Object.<anonymous> (C:\Program Files (x86)\Sfdx\client\node_modules\salesforcedx-templates\node_modules\yeoman-generator\lib\index.js:427:27)
>     at C:\Program Files (x86)\Sfdx\client\node_modules\run-async\index.js:25:25
>     at new Promise (<anonymous>)
>     at C:\Program Files (x86)\Sfdx\client\node_modules\run-async\index.js:24:19
>     at self.env.runLoop.add.completed (C:\Program Files (x86)\Sfdx\client\node_modules\salesforcedx-templates\node_modules\yeoman-generator\lib\index.js:428:13)
>     at runCallback (timers.js:705:18)
>     at tryOnImmediate (timers.js:676:5)   generatedMessage: false,   name: 'AssertionError [ERR_ASSERTION]',   code: 'ERR_ASSERTION',  
> actual: false,   expected: true,   operator: '==' } 10:25:38.556 sfdx
> force:project:create --projectname Amodev --outputdir
> c:\Users\shruthim4\Documents\VS Code --template standard --manifest 
> ended with exit code 0

I am facing the same issue even when I tried to create project from CLI. I have installed latest Salesforce CLI and I have added correct path to Environment variables still I am facing this issue. Please help me revolve this issue.

0

This appears to be the same error as this post

Have you tried the approaches mentioned in https://success.salesforce.com/answers?id=9063A000000pwoMQAQ i.e.,

  • Installing the x64 version of the CLI and changing the PATH environment variable to point to that
  • Rename and move "Salesforce CLI" folder to a path without space in its name
  • Open visual studio code as an administrator
  • Ensuring you have installed the appropriate version of CLI i.e., x64 CLI or x86 that your machine would support
| improve this answer | |
  • I am follows all the above mentioned steps, still I am getting the same error – Salesforce fan Jun 16 at 10:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.