I am trying to select only files that are important for the current Project, not all the content in my Dev org. When I create a Project in Eclipse, I am unable to select content as you can see in the screen shot below. How do I select only specific files?

new Force.com Project wizard

  • Might be the user you are trying to login in eclipse does not have the classes accessed by his profile.
    – Bforce
    Mar 25, 2014 at 18:25
  • 1
    Same issue. Running Fedora. Replicated across multiple machines. Get a blank screen for "Choose Initial Project Components". If we select "Finish" from that screen, then it only pulls down classes in a folder and the other Apex components have a folder, but are empty. Despite the xml showing "*" was selected for VF Pages for example.... Have to use an old standalone version of the Force.com IDE for now.
    – user10596
    Aug 28, 2014 at 20:24

3 Answers 3


I know this is a late answer, but I've been having this issue over the past couple of days as well and found a solution so posting my answer here for anyone else.

Using Eclipe helios, kepler and luna with Force.com IDE v29 I had exactly the same problem (but on windows).

Turns out if I switched to the Java perspective in Eclipse, rather than Force.com perspective (in the top right corner), creating Force.com projects works absolutely fine.

Hope this is helpful for anyone else having this problem!

  • 1
    I can confirm jeff's answer (I tried to comment and vote it, but I'm short on reputations). I'm running ecplise kepler and the force ide winter '15 (35.0). If the force perpective is open and I'm trying to create an new project, it will end up in an empty project content screen. no metadata ressource can be selected. If I switch to the java perpespective and creat a new force.com project then everything works fine. I can chosse the needed metadata (classes, triggers, pages etc.) and save the project. So from my point of view jeff's answer is the right one.
    – user26426
    Nov 17, 2015 at 18:43

I had had same issue so, when blank screen shows you just need to maximize and then restore to the standard window size, thus all initial content is shown.

Hope that works your you.

  • surprisingly, this worked like a wonder! Jan 11, 2018 at 23:37
  • This still happens in the current versions (37 and 38). Per Andres Cubillos answer, all you need to do is expand the window -- I just grab the right side of the window and expand it outward slightly, and the contents shows up. Apr 9, 2018 at 19:17
  • @LawrenceCoffin 37 and 38 are most definitely not the current versions. You're over a year behind.
    – Adrian Larson
    Apr 9, 2018 at 20:17

From looking at your screen shot, I see something underneath about your embedded browser not being configured. Perhaps if you take care of that issue, you might have some success. Otherwise, you might want to continue with creating the project, then see if you're able to change the metadata in your project.

Often, these issues tend to be related to the configuration of your Eclipse installation; particularly to your Java JRE path. I'd suggest you look in Eclipse's Preferences under Java->Installed JRE's to see if it matches the path to where the Java JDK is installed at on your machine. Also look in your machine's path statements to see if there's a Java path statement listed there.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .