0

when I visualize a VisualForce page rendered as PDF on the Salesforce mobile application the image of the checkboxes appears with a black background. I used the following two versions of markup, but neither worked:

  1. <img src="https://mydomain.my.salesforce.com/img/checkbox_checked.gif" style="background-color:white;"/>
  2. <img src="/img/checkbox_unchecked.gif" style="background-color: white;"/>
  • 1
    There's a good chance the PDF rendering engine cannot handle transparency in GIF files or it defaults the alpha layer to black. I would consider setting the background to white in the image itself. Additionally, the rendering engine for PDFs in Salesforce is fairly old (by web standards), I would also try background: #ffffff; to make sure it's not the attribute of background-color that is giving you issues. – nbrown Jun 10 at 12:33
  • @nbrown thanks for your answer it works on desktop! – maya Jun 10 at 13:03
  • @nbrown i tried with [background: #ffffff; ] it still doesn't work!! – maya Jun 11 at 7:46
  • Like I said, changing the background is guaranteed to work even if it is a heavy handed solution. – nbrown Jun 11 at 12:33
  • @nbrown it still doesn't work! – maya Jun 11 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.