1

I am trying to deploy the Flow-meta.xml file using vs code with salesforce dx to my scratch Org. I am getting the error 'Error parsing file: 'RecordAfterSave' is not a valid value for the enum 'FlowTriggerType'.

Interesting fact is am able to deploy it to one of the sandbox but not to my scratch org.

3
  • Did you ever get this to work? I just now ran into same problem myself. – ddeve Jul 16 '20 at 15:27
  • Hi I found thatflow trigger type 'RecordAfterSave' is available after 19 Jul 2020 relaease to summer 20. I learned that scratch orgs are cloned from production i.e they will have the same release version which is not summer 20. So I can deploy easily to my sandboxes. – AnkushSalesforce Jul 18 '20 at 0:53
  • I'm trying to deploy to a scratch org on Summer 20 so I guess new issue. You had a version mismatch which is different. – ddeve Jul 18 '20 at 3:20
1

Did you see this post from me a few months ago? Sounds like could be the same.

3
  • Hi @ddeve Thanks for Answering. How to update sfdx in Vs code – AnkushSalesforce Jun 11 '20 at 3:39
  • "sfdx help" - gives you some of the commands. "sfdx update" - updates your version OR "npm update --global sfdx-cli" – ddeve Jun 11 '20 at 13:30
  • I have updated the CLI and sfdx. Also did what is mentioned in the POST and reterieved am still not able to deploy to scratch ORG – AnkushSalesforce Jun 19 '20 at 1:45
1

I learned that the issue was due to the triggertype 'RecordAfterSave' was only available in Summer 20 and my PROD instance was not an the summer 20 though its sandbox were upgraded earlier. It has been resolved now by adding a 'release' parameter to my "project-scratch-def.json" file for creating a scratch ORG. Here is the example below.

{
  "orgName": "My Scratch",
   "release" :"preview",
  "edition": "Developer",
  "hasSampleData": false,
  "features": [
    "Communities",
    "FieldService",
    "LiveAgent"
   ]
 }

Note: You might have to remove 'release' from son file once the Prod is upgraded to latest release version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.