0

I'm trying to use VSCode for my Salesforce Org, I set it up and connected to Salesforce org. and whenever I'm trying to run the Classes, Triggers. it showing me this problem below

An unsupported Java version was detected. Download and install [Java 8](https://java.com/en/download/) or [Java 11](https://www.oracle.com/technetwork/java/javase/downloads/jdk11-downloads-5066655.html) to run the extensions. For more information, see [Set Your Java Version](https://forcedotcom.github.io/salesforcedx-vscode/articles/getting-started/java-setup).

NOTE: I have a version 11.0.7. which is current. I tried to use Java 8 current version as well, but still showing up this error. and Yes I tried through terminal checking the version of Java and changing the versions between 11.0.7 and 8.

thanks in advance

EDIT: Does it makes difference downloading ZULU?

0

I tried with jdk-11.0.7 version and it's works.

In my case, I realise that the config "salesforcedx-vscode-apex.java.home" was replaced accidentaly because the file .vscode/settings.json was not ignored on the git repository.

Hope I can help.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.