6

I have created a Visual Flow in Salesforce and I wish to use the option of a Multi-select Checkbox. I cannot seem to find a way to map these Multi-select checkbox choices to a record. I have tried mapping each choice to a checkbox and also each choice to a multi-select picklist value but I cannot seem to get it to map. Can someone help me with this?

  • Can you show an example of your fields on your Salesforce object please? – Andrew Fawcett Mar 24 '14 at 13:51
  • 1
    The values get stored as a concatenated string, seperated by semicolons. You can get the values using formula's or an apex call. When using a dynamic lookup for multi choices, only the last checked value is stored (which, in fact, renders the whole dynamic lookup on multi choicelists useless! oh salesforce why). – westerforce May 12 '15 at 14:09
1

I have been able to create a record populated via a Multi-select Picklist.

This is my screen setup...

enter image description here

enter image description here

This is my flow..

enter image description here

I then mapped my Multi-Select Picklist to the Record Create task

enter image description here

When I ran the flow it resulted in my field displaying as follows on the new record...

enter image description here

enter image description here

Note that i did find the following statement (second bullet) in the documentation, section Multi-Select Choice Fields Overview, which seems to suggest if i read the record i cannot map the value to be displayed...

You can’t populate multi-select picklists in flows with the picklist values of standard or multi-select picklist fields elsewhere in your organization.

  • Hi Andrew. Thanks for your reply. I can create and map multi-select picklists but I am having an issue creating Multi-select Checkboxes. Since there is no Multi-select Checkbox Field type for records in Salesforce, I cannot seem to match the multi-select checkbox in the flow to anything. As a way of resolving this for now I have just reverted back to using normal checkboxes and mapped them to checkbox fields on the record. – Clehan1 Mar 24 '14 at 13:48
  • I'm sorry you did mention that, apologies i misread the question. I am though curious what Salesforce field type are you trying to map to a Multi-select Checkbox field type? – Andrew Fawcett Mar 24 '14 at 13:50
  • I have tried matching the Multi-select Checkbox type to the Checkbox field type and multi-select picklist field type. – Clehan1 Mar 24 '14 at 13:52
  • Hmmmm my first thought is i'm not surprised this use case is not supported, but i sense i may still be missing a bigger picture, speaking of which did you see my request to see some more information on your fields and use case above? – Andrew Fawcett Mar 24 '14 at 14:39
  • There are over 100 fields for this Object so I do see why any of them would be relevant to the multi-select checkbox? I have decided to use original checkboxes in the Flow so I can map them directly to the checkbox on the object's fields. This workaround has proved to be far easier and effectively the exact same thing. Thank you for your help. Much appreciated. – Clehan1 Mar 26 '14 at 10:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.