2

I got in my iOS app the MarketingCloudSDK (v6.4.2).

As I got this email from Salesforce:

"If you do not update your application to use the .p8 Auth Key by July 25, 2020, then your iOS messages will fail."

I will follow this actions: https://org62.my.salesforce.com/sfc/p/#000000000062/a/0M000000OMhD/Ssu9rGuCZ7kc1aAvxGmqQGIhEK_hPvOxALWwdB9D1CE

But then, do I also need to upgrade the latest MarketingCloudSDK (v7.1.1)?

If so, Am I going to be able to still send pushes to the users who have a previous app version?

1
  • As answered by @Naveen, you do not need to upgrade, but upgrading is always a good idea ;) – Bill Mote May 28 '20 at 15:39
3

You don't have to do any changes in SDK. All you will be configuring auth keys in Marketing Cloud UI instead of certificates.

Using the steps in the same URL which you have provided in your question - https://org62.my.salesforce.com/sfc/p/#000000000062/a/0M000000OMhD/Ssu9rGuCZ7kc1aAvxGmqQGIhEK_hPvOxALWwdB9D1CE, change certificate to auth keys.

So, you can still use the same sdk version to send push notifications.

But if you don't change it to Auth keys by July 25th then push notifications for ios from marketing cloud will not be send.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.