2

after making updates to a process builder for task record inserts, I am trying to deploy it - using change sets - to the Testing sandbox from our Development sandbox. The previous deployment - which contained 9 Email Alert immediate actions - worked fine in Testing sandbox and is presently activated and has been running for about a month now.

However, after adding a couple more conditions (that use Text Field Immediate Actions) on the Development Sandbox's process builder today, I am getting this error during deployment to Testing sandbox: myRule_1_A1 (Action) -We can't find an action with the name and action type that you specified. I have no idea why the process builder is not deploying. Here are some screen scrapes of the updates I made to the process builder. enter image description here enter image description here

4
  • between the target and source org, have you renamed any of the Process Builder or Email Alerts?
    – cropredy
    May 28, 2020 at 0:07
  • The error is probably not coming from this newly added node. May 28, 2020 at 1:16
  • @cropredy I have reinspected this and I don't see any naming differences for the email alerts between Development sandbox and Testing sandbox. May 28, 2020 at 12:45
  • I have the same problem with flow. The flow call apex method and get sorted records. When I try to deploy my changes to another sandbox have same problem "Error:(1, 1) Catch_Same_Products (Action) - We can't find an action with the name and action type that you specified." P.S. All files were deployed in the sandbox before I tried to deploy my flow.
    – user89595
    Jan 24, 2022 at 8:23

6 Answers 6

4

I'll add another possible reason for this (as it happened to me today):

Deploying a Flow with actions that included sending emails. These require an Workflow Email Alert to be deployed but if the Workflow is not part of the deployment package, the deployment fails with a message that starts with:

We can't find an action with the name and action type that you specified
0

Thanks to all @cropredy and @hengky for their help and I guess both of them were partly correct but here is the full answer. Unbeknownst to me,one of the client's SF Admins had created a new email alert which uses my email template tht my process builder somehow uses. Furthermore, I believe it may also be somehow overriding my original email alert because it is sending out email notifications not just to the assignee of the Task but also CC'd email addresses. So the issue basically was that an email alert - that I did not create - was not put into the change set. Solution: Add that email alert into the change set.

0

You will also have to include the Email Template if not already ported. I also had an issue with non-matching user names so used an 'additional' email address. Once ported, I added back the Users.

0

In my case where the 'missing' action is an Apex action (ie invocable method), the solution was to check the Apex class being referenced in the flow action step whether it is Active and/or re-executing the corresponding test class for that class.

It seems that this happened as a result of a change in the Apex class (ie the Invocable method is new and just deployed) that is still not 'seen' by the change set. So it's all a matter of 're-comipiling' by way of the test method execution.

Researching through similar issues, this error should've been fixed as a bug by SF, but I still experienced it now. See https://trailblazer.salesforce.com/issues_view?id=a1p3A000000KSXZQA4 and Error Occurred During Flow Action name not found: null. Need to force Class Compilation?. Hope this helps.

Hope this helps.

0

I also faced when deploying a flow which is having a custom notification as an action. After trying numerous steps I found that the notification setting was missing. When I deployed notification types and notification settings with the flow, it worked like a charm. Refer here for more info.

0

Complementing the answers....here is the full structure that you should use to avoid this error at deploying a Flow that uses an EmailAlert and this alerts uses (obviously) a EmailTemplate

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<Package xmlns="http://soap.sforce.com/2006/04/metadata">
    <types>
        <members>FlowName</members> 
        <name>Flow</name>
    </types>    
   <types>
        <members>ObjectName.EmailAlertName</members>
        <name>WorkflowAlert</name>
    </types>
    <types>
        <members>ObjectName</members>
        <name>Workflow</name>
    </types>    
    <types>
        <members>unfiled$public/EmailTemplateName</members>
        <name>EmailTemplate</name>
    </types>
    <version>53.0</version>
</Package>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.