I have set up a few scratch orgs, but am running into an issue with VSCode. When connected to a "normal" developer org, I am shown various options and context menus (eg, deploy manifest etc). When I am connected to a scratch org, all context options go away.

I've already tried logging out and re-authorizing the scratch org with a username/password, but that had no effect.

How can I fix this?

Screenshots. When in context of scratch org: enter image description here

When in context of a regular org:

enter image description here

3 Answers 3


One work-around I noticed that seems to have worked for me is:

  1. Generate a password for your scratch org user via

sfdx force:user:password:generate

  1. Perform a web authentication via SFDX

sfdx force:auth:web:login --instanceurl https://test.salesforce.com

  1. RESTART VSCODE and re-open the project. Metadata/tools now show up.

This feels like a bug - EG, after the weblogin credentials are set, metadata tools should become available automatically without having to restart the IDE.


This is as per the design. If you need this capability and have feedback I suggest raising it on the project github.

You can use the issue tab to describe your need and that would let the product team consider and prioritize it.

  • I think this issue is asking for the same thing already. May 13, 2020 at 18:15
  • I suggest leaving a comment to get more attention. Now the sandboxes will have source tracking capability so it might be relevant. I think the other problem in allowing was will customers understand "source tracking" and non-scratch orgs which I think slowly community is adopting. May 13, 2020 at 18:17

Another option in VS Code is to open the command palette and choose "Developer: Restart Extension Host" so you don't have to close and re-open the editor.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .