4

How do I change the textual value of 'Closed' to "I like cheese" in English, and 「チーズが好き」 in Japanese?

enter image description here

"Closed" isn't an actual stage, so it's not in the "Stage" picklist translations:

enter image description here

And I've tried adding a translation under the "Forecast category" picklist translations, but this isn't reflected on the Opportunity record screen, even after several days:

enter image description here

enter image description here

As you can see, it still says "Closed". So how do I translate this value?

P.S. I also tried in Japanese to no avail (since the requirement I have received is to change it in both English and Japanese):

enter image description here

enter image description here

2

4 Answers 4

3
+50

It seems the answer is "no".

I have no documentation to support it other than to say I see the same behavior you do even following all the scenarios presented in these answers.

When you change languages, it's automatically translated and it's the language-specific version of "Closed". The fact that it's automatically translated hints that this may be some standard value that you cannot change.

The screenshot @Roxana pasted shows an example as it shows the German word for "Closed". I see the same when setting my language to German, but I'm not able to change it to be a different word as you're asking (and as you can do for the custom picklist values). It seems it will always be the value of Closed.

0
0

You cannot edit the Closed Won stage directly, but there is a workaround. You can create a new picklist value with type as Closed/Won, give it a probability 100% and name it whatever you want then simply deactivate the standard Closed(Won) picklist value.

Stage

Hope it helped. Cheers!

4
  • That just seems to add it to the Close This Opportunity screen, but doesn't change the name of the "Closed" button. May 13, 2020 at 7:20
  • exactly which "Closed" button are you referencing to? May 13, 2020 at 11:54
  • The one underlined in red in my screenshot towards the top of my question. May 13, 2020 at 13:25
  • Can you either answer my question or delete this answer? It makes it look like I have multiple answers, when in fact none of them address my question. May 26, 2020 at 0:55
0

Go to Setup-> Translation Workbench -> Translate. Then select the component to be "Picklist values" and then the object "Oportunity" and translate the Forecast Category picklist values since Closed is a forecast category, not a stage. I tested in my dev org and it worked.

enter image description here

1
  • 2
    Hey folks, it seems like there's some mutual misunderstanding and frustration here so I'm going ahead and clearing out the comments. Let's let that be a reset and understand that for whatever reason it looks like this route isn't working out.
    – David Reed
    May 26, 2020 at 15:20
0

In case the below editing of the Opportunity Path does not work, you may need to open a Salesforce Case and they can help further and give a definite answer to this.

Editing Path Step 1.enter image description here

Edit Path Step 2 enter image description here

Try editing the Path in Lightning Experience Note for Lightning, these are now called Paths, formerly Sales Process

In lightning go to Setup-> Quick Find Box =- > Type Path Settings Adjust the Path for Opportunity. I believe that will work. Reference: https://trailhead.salesforce.com/en/content/learn/modules/lex_migration_whatsnew/lex_migration_whatsnew_crm

That is an Opportunity Stage. The reason you are not seeing it change is that you need to change the Sales Process from 'closed' to your new custom stage as well. Try this to edit and customize Opportunity Stages and make your custom stage for 100% - your own custom stage. This is key -> After that you need to change the Sales Process for that type of Opportunity to include the new stage that you made. then you will see it change

Switch to classic temporarily: Setup-> Customize->Opportunities->Fields->Stage

https://trailhead.salesforce.com/en/content/learn/modules/admin_intro_opptys_leads/admin_intro_opptys_leads_opportunities

27
  • It's not a stage. It's not in the stage picklist. It's in the forecast category picklist, but translating the forecast category doesn't make a blind bit of difference. This has all been in my question from day one. May 22, 2020 at 6:14
  • I know you are seeing a picklist but that picklist is getting its info from stages. Every type of Opportunity has its own Sales Process which you can edit the process for custom stages. The picklist you are referring to is making a call to the stages of your process to get its choices in the picklist. Make a new stage and then change the process for the stage to end on your custom stage which will equal 100%
    – Edward
    May 22, 2020 at 6:20
  • But even Sales processes doesn't show "Closed"? I must be missing something. Have you managed to change the text of "Closed" with the method you are suggesting? May 22, 2020 at 6:22
  • Switch to classic temporarily: Setup-> Customize->Opportunities->Fields->Stage
    – Edward
    May 22, 2020 at 6:24
  • I've done so, but again I don't see "Closed". Screenshot May 22, 2020 at 6:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .