1

I'm trying to create a Scratch ORG, but everytime I get the same error:

Failed to deploy settings to scratch org.

When I run Terminal, I got the following message:

shape/settings/Bot.settings Bot Not available for deploy for this organization.

I checked the repo of the project, and this path doesn't exists. The Devhub is configured properly, and I think I'm executing the command in the right path.

Anyone can help me solving this?

Other Infos

Order I executed the commands:

sfdx force:auth:web:login -a MyDevHub -r https://login.salesforce.com;

sfdx force:org:create -f config/project-scratch-def.json -v MyDevHub -a ScratchXXX - I got the error Here;

My Path: C:\Users\myUser\Desktop\project\rootFolder>

Scratch Org Definition File:

{"orgName": "MyProject",

  "edition": "Enterprise",

  "features": [

    "PersonAccounts",
    "ServiceCloud",
    "Entitlements",
    "Communities",
    "PartnerCommunity",
    "MarketingUser"
  ],
  "settings": {

    "communitiesSettings": {
      "enableNetworksEnabled": true
      },
    "chatterSettings": {
      "enableChatter": true
    }
  }
}
sfdx force:config:list
=== Config
Name                   Value                   Location
─────────────────────  ──────────────────────  ────────
defaultdevhubusername  SomeOtherOrg            Global
defaultusername        MyDevHub                 Local
  • Could you edit to share your scratch org definition file? – David Reed May 7 at 22:20
  • Edited it @DavidReed, thanks for the help! – Growred May 7 at 22:25
  • Interesting. Do you have a configuration set to pin your Salesforce API version in SFDX, perhaps? sfdx force:config:list. – David Reed May 7 at 22:26
  • I don't understood well your question. I executed the line of code you sent me: defaultdevhubusername SomeOtherOrg Global defaultusername MyDevHub Local It didn't returned the APi version of any of the orgs. The error could be related to the fact that :"defaultdevhubusername " is not assigned to the org that I'm currently working with? – Growred May 7 at 22:33
  • Added to the OP for better understanding! Thanks again! @DavidReed – Growred May 7 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.