2

On every release I run into some sort of trouble with this testing phase and having the preview CLI core plugin installed. The instructions are short and clear HERE

That said, those instructions don't work for me and the preview version does not install and the existing version remains after running the following command:

sfdx plugins:install salesforcedx@pre-release

Screenshot of commands

Any idea why the pre-release would fail to install?

UPDATE: This issue has since been resolved, see best answer for details enter image description here

4

This seems to be an issue in the Salesforce CLI plugin for pre-release. I am going to inform the team about it.

You can uncover the real error by executing below command

sfdx plugins:install salesforcedx@pre-release --log-level=error

Here is the original error

error Couldn't find any versions for "salesforcedx-templates" that matches "49.0.1-0" Error: Couldn't find any versions for "salesforce-alm" that matches "49.0.6" at MessageError.ExtendableBuiltin (/Users/mohith.shrivastava/.local/share/sfdx/client/7.56.1-2773b53bf5/node_modules/yarn/lib/cli.js:721:66) at new MessageError (/Users/mohith.shrivastava/.local/share/sfdx/client/7.56.1-2773b53bf5/node_modules/yarn/lib/cli.js:750:123) at Function. (/Users/mohith.shrivastava/.local/share/sfdx/client/7.56.1-2773b53bf5/node_modules/yarn/lib/cli.js:50545:13) at Generator.next () at step (/Users/mohith.shrivastava/.local/share/sfdx/client/7.56.1-2773b53bf5/node_modules/yarn/lib/cli.js:310:30) at /Users/mohith.shrivastava/.local/share/sfdx/client/7.56.1-2773b53bf5/node_modules/yarn/lib/cli.js:321:13 at process._tickCallback (internal/process/next_tick.js:68:7)

UPDATE

This has been fixed now and you should be able to install the plugin now.

| improve this answer | |
  • I will keep updating this answer as I hear more about this. – Mohith Shrivastava May 7 at 3:26
  • CLI team will fix this tomorrow first thing. Thank you – Mohith Shrivastava May 7 at 4:01
  • This is been fixed now. – Mohith Shrivastava May 7 at 4:24
  • 1
    Wow - that was quick @Mohith! Thank you for your support with this issue. – Glen De Marcos May 7 at 5:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.