0

when I try to open the developer console it keeps loading.

enter image description here

Finally it stays like this:

enter image description here

And I can't access any of the tabs.

enter image description here

Does anyone know how I can reset to get it working again? Thanks a lot.

1
  • 2
    Try another browser. If you have any addons or extensions, disable it. Clear the cache and make sure you have Author apex permissions. – manjit5190 May 3 '20 at 9:02
2

You can follow the steps below taken from this knowledge article

  1. Login and open Developer Console by Chrome
  2. Open Developer tools and select Network
  3. Upon reload on Developer Console You will see the following request to get IDEWorkspace https://na1.salesforce.com/services/data/v31.0/tooling/query/?q=SELECT%20Id%2C%20Name%2C%20Content%20FROM%20IDEWorkspace%20WHERE%20Id%3D%271deO00000004EkkIAE%27 ID of IDEWorkspace is "1deO00000004EkkIAE".
  4. Login to Workbench and go to REST Explorer
  5. do GET for /services/data/v29.0/tooling/sobjects/IDEWorkspace/1deO00000004EkkIAEYou will see the content of IDEWorkspace
  6. Select DELETE. This will delete the workspace
  7. Re-open Developer Console You will see that menus are available.
  8. Choose an existing workspace or create a new workspace

Also, try to have minimum tabs opened at a time when working in the developer console, since multiple tabs opened increases the load time. Sometimes, as a workaround , when a developer console opens in a new window, copy the url from the new window and paste it in the same window, from where you have opened developer console.

1
  • thanks a lot, that works for me. – Davidenserio May 3 '20 at 15:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.