0

I'm getting this error when trying to create an Opportunity Contact Role via the REST API:

CANNOT_INSERT_UPDATE_ACTIVATE_ENTITY: entity type cannot be inserted: Opportunity Contact Role

I suspect this is due to a missing permission somewhere, because it works okay when using a different User, in a sandbox.

If I go to Administration -> Users -> Profiles -> [my custom profile] -> Object Settings -> OpportunityContact Role, it shows that I have the same set of permissions as the other User (which is able to create Opportunity Contact Roles):


| Field Name       | Read Access | Edit Access |
|------------------|-------------|-------------|
| Contact          | ✓           | ✓           |
| Created By       | ✓           |             |
| Last Modified By | ✓           |             |
| Opportunity      | ✓           | ✓           |
| Primary          | ✓           | ✓           |
| Role             | ✓           | ✓           |

What could I be missing here?

  • Are Opportunity Contact Roles enabled (see Sales Settings)? That's about the only thing I could think of. – sfdcfox Apr 28 at 19:28
  • Yes, they are enabled. – dipea Apr 28 at 20:15
  • if you try and add the OCR in the UI, what error do you get? Do you even see the New button? – cropredy Apr 29 at 2:45
  • This is an API only user so I don't have access to the UI – dipea Apr 29 at 6:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.