1

I'm wanting to generate API documentation using SfApexDoc with the "global" scope. However, I can't get it to work. I'm using a Windows 10 PC. What I've done:

  1. Downloaded the JAR using the link on the GitLab wiki for SfApexDoc
  2. Set up an external tool: enter image description here

Executing this external tool does something (just what, I don't know) since it takes a while to terminate, but the output folder remains stubbornly empty. The external tool console log shows nothing at all.

When I run the generated command in a Command window (with an update to specify the full path to the java app) and adding "-d" for debug I do get some output, like:

SfApexDoc version 1.3.0

Class: AchievementController.barInfo
  properties: achType finalGoal highLimit lowLimit starTitle width
  methods: barInfo
Class: AchievementController
  properties: AchType finalGoal highLimit lowLimit numberProgress starTitle width
  methods: AchievementController ...

later followed by more output like:

parseProjectDetail():
parseHtmlFile():
Processing: createshiftdemandsforjoborders
Processing: client_shifts
Processing: dynamicsearchselectcontroller
Processing: shiftschedulingcontroller2_test
...

But even then the output folder remains empty.

Anyone spot what I'm doing wrong?

2
  • 1
    A little late to this, but it works for me. The only difference on my end is that I'm specifying my full path for my source directory -s C:\Users\Kris\IdeaProjects\ProductionDX\force-app\main\default\classes Jun 6, 2020 at 20:37
  • Thanks Kris. I added an answer about how this issue went away with a re-built Windows 10 install with all the gubbins.
    – Phil W
    Jun 6, 2020 at 21:13

1 Answer 1

1

I had to move to a new PC and re-installed everything there. This actually solved the issue and I don't really know why. Regardless, the following combination works:

  1. The SfApexDoc 1.3.0 JAR downloaded from the SfApexDoc GitLap project wiki home page
  2. OpenJDK 14 downloaded from the OpenJDK site
  3. IntelliJ IDEA 2020.1.2 (Ultimate Edition)
  4. Illuminated Cloud 2 (version 2.1.2.4)

This runs happily on Windows 10.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .