1

When using the Ant deploy tools to deploy the System Administrator (Admin) profile into a Spring '14 sandbox, I get this error reported:

Error: profiles/Admin.profile(Admin):The user license doesn't allow the permission: CreateWorkBadgeDefinition

The profile does not mention "CreateWorkBadgeDefinition" and I don't see any checkbox in the target org profile editing page with any of the keywords in it. Googling returns some (non-exact matches) to Work.com documents.

Note that the profile that is being deployed was created in a Winter '14 developer edition org.

Does anyone have insight into this or work-arounds for it?

PS

Got my deployment done in the sandbox by just leaving out the Admin profile.

Just ran the same deploy to a second sandbox on the same node (cs14) with the Admin profile included and it worked.

Odd: looks like I'll have to flip a coin to decide what to do for the production deployment in a few days time.

3

Same issue showed up on one of our Sandboxes just today. We worked around it by manually changing the Admin.Profile XML, forcing the permission to be set to False as the first userPermission in the list.

<userPermissions>
    <enabled>false</enabled>
    <name>CreateWorkBadgeDefinition</name>
</userPermissions>

This allowed the build to be successful, so we reverted the XML to the original version. To try this you need to use API v29 or higher.

2

The actual issue is that you must enable Work.com "Thanks" mode in the target instance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.