0

I am trying to create an AccountUser and my response says OK but the account does not actually gets created.

Request:

<createrequest xmlns="http://exacttarget.com/wsdl/partnerAPI">
    <objects xsi:type="AccountUser">
       <partnerkey xsi:nil="true"></partnerkey>
        <objectid xsi:nil="true"></objectid>
        <client>
            <id>MID</id>
        </client>
        <userid>user_name</userid>
        <password>password</password>
        <name>Full Name</name>
        <email>sample@email.com</email>
        <activeflag>true</activeflag>
        <isapiuserspecified>false</isapiuserspecified>
        <isapiuser>false</isapiuser>
        <islockedspecified>false</islockedspecified>
        <islocked>true</islocked>
        <mustchangepassword>true</mustchangepassword>
        <mustchangepasswordspecified>true</mustchangepasswordspecified>            
         <defaultbusinessunit>MID</defaultbusinessunit>
         <userpermissions>
            <useraccess>
                <id>3</id>
                 <idspecified>true</idspecified>
             </useraccess>
         </userpermissions>
        <!--<ssoidentities>
            <ssoidentity>
                <isactive>true</isactive>
                <federatedid>fdiaz</federatedid>
            </ssoidentity>
        </ssoidentities> -->
    </objects>
</createrequest>

Response:

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing" xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd" xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">
    <soap:Header>
        <wsa:Action>CreateResponse</wsa:Action>
        <wsa:MessageID>urn:uuid:6b5ecad6-f2df-4342-9968-79b67b0e911</wsa:MessageID>
        <wsa:RelatesTo>urn:uuid:5a2f673b-ee57-4516-aac1-5db3925c9110</wsa:RelatesTo>
        <wsa:To>http://schemas.xmlsoap.org/ws/2004/08/addressing/role/anonymous</wsa:To>
        <wsse:Security>
            <wsu:Timestamp wsu:Id="Timestamp-d0c25d42-07e2-474a-b245-3e17fb0c6e9df">
                <wsu:Created>2020-04-17T15:52:55Z</wsu:Created>
                <wsu:Expires>2020-04-17T15:57:55Z</wsu:Expires>
            </wsu:Timestamp>
        </wsse:Security>
    </soap:Header>
    <soap:Body>
        <CreateResponse xmlns="http://exacttarget.com/wsdl/partnerAPI">
            <RequestID>80680c1b-c2f7-4d6C-9598-416068491EEE</RequestID>
            <OverallStatus>OK</OverallStatus>
        </CreateResponse>
    </soap:Body>
</soap:Envelope>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.