0

I am stuck on this and will appreciate any help please:
We have implemented a flow inside a Partner Community, which includes a couple of screens and an "Action" item. This "Action" item calls an external API, which we defined using appropriate JSON via "External Services" option of SF. Basically, the API call sends an ID of an object which is then manipulated outside the SF (with REST API) and updated:

enter image description here

The flow executes correctly when run inside an org, but is interrupted on the "Action" element. The API call is being executed (both the endpoint receives a "GET" and an object is updated correctly), but the "Screen" item that has to be shown after the "Action" is simply not showing and insted a white screen is shown permanently:

enter image description here

Things I've tried:

  1. I suspected the "Launch Flow in Modal" feature to be causing the problem, but it works fine in the org and the same Flow implemented regularly in Partner Community still produces the same problem.

  2. I tried to clone the Partner Profile and check the box on "Allow API", but it seems it concerns rather SF Rest API and not "External Services".

  • What does the apex log show when executing this from the community? – stackasaur Apr 22 at 20:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.