1

I have got a bit fed up of waiting for partners to reply so are setting up Marketing Cloud by myself (Yay!). Anyway it was all going really well, we have had the domain configured, followed a few Trailheads and I was setting up marketing cloud connect into our Service Cloud instance. It all went swimmingly.

https://trailhead.salesforce.com/en/content/learn/modules/marketing-cloud-connect/test-the-connection

I got to the end of the trailhead and sent the test email to a new lead I created. It took about an hour but the send failed without any message (sent from Service Cloud instance accessing Marketing Cloud that way). I sent it again after I was 100% sure the domain was set correctly (now verified from address) and I receive the error:

Error queuing send.

I have checked the MC configuration from the trailhead and everything appears to be correct. A quick google showed me this article , I also looked into the Data Extension that was created for the lead report in Email Studio and it shows no records.

Workflow appears to be activated and synching but naturally I am a beginner with all of this. Just want to get it right and not go undoing a lot of stuff as it maybe something obvious/silly. Yes I have contacted a freelancers with experience to see if someone can help short term too :(

This appears to offer some advice maybe not included in the Trailhead, will go through this now: https://help.salesforce.com/articleView?id=mc_co_connect_the_clouds.htm&type=5

3
  • It may be too late to answer to your question now, but let me leave a comment. I ran into the same problem and found this page on my way of Google search. Right after I was disappointed with the fact that there was no comment here, I was finally able to crack down on this trouble! (Yay!) You may want to check the contents of the email you are sending. Marketing Cloud complies with CAN-SPAM, and we can send only emails with a billing address, an unsubscription link, and so forth.
    – Hiroki
    Feb 6, 2021 at 6:05
  • Welcome, @hiroki! Converted your answer to a comment for you.
    – Matt Lacey
    Feb 8, 2021 at 6:00
  • Hi @Hiroki, Can you please explain your answer, i didn't understand, I got the same problem Apr 16, 2021 at 10:18

2 Answers 2

2

I had faced the same issue and was stuck for few days. And then finally realized the error was because I was sending from an email address that has not been verified within Marketing Cloud. Try the following steps to troubleshoot.

  • Go into Marketing Cloud > Email Studio> Email > Admin > Account Settings> From Address Management
  • Add the email address of the user. This will trigger an email where they need to confirm that Marketing Cloud can use it in sending.
  • Then, go back to Salesforce CRM (Sales Cloud/Service Cloud) and send the email using the verified email.

Hope this helps. Cheers

0

I had the same problem and I want to share my fixing way.

  1. Firstly I tested with an email template from Marketing Cloud and I couldn't send.
    • Email Studio>Email>Create a Sender Profile with your email and verify
  2. I encountered "No verified Send Classifications yet" problem
    • Email Studio>Email>Create a Send Classification
  3. I encountered "The email is missing a valid physical mailing address, which must be present on commercial emails per the federal CAN-SPAM Act." error
    • I updated my email content and added "Physical Mailing Address" to my content.
  4. I had one more problem (I didn't get any error but the mail was not sending)
    • The problem source was company address information missing Setup>Company Settings>Account Settings> Filled City/Street/State etc. address fields.

I hope it will be useful to you

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .