6

getting a strange issue on a Lightning page. In the background, I'm trying to update a Long Text Area field with Apex (before update trigger) but it seems to throw this error whenever I try to update the value of that field.

Any ideas?

enter image description here

  • This looks like a JS issue or a handler issue. Would you able to post the relevant code? – manjit5190 Apr 10 at 20:47
  • That's the confusing part @manjit5190 - this is a standard layout, so no JS code written on our end. I submitted a case to Salesforce and apparently they have a few reports of this – McD Apr 10 at 21:25
  • Do you have the debug mode turned on for lightning and if you disable the trigger does it works fine? – manjit5190 Apr 10 at 21:45
  • Correct, I started disabling everything in the trigger and got it down to one line: when I update the value of the Long Text area. And yes, lightning debugger shows the same error and stack trace. – McD Apr 10 at 21:51
  • 1
    This known issue mentions the same error, but the description is sparse and just says to contact support – Kris Goncalves Apr 13 at 23:54
1

As everyone else noted, this is a known issue - apparently this is scheduled to be fixed by April 21, 2020 (that's what they told me in my Salesforce Case).

For the time being, the workaround I'm using is to change the Long Text Area field to a Rich Text field, it seems to have resolved the issue.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.