0

We want to use InBox feature only on iOS and Android applications (without push notifications).

Based on the LearningApp sample there is no option to disable push notifications during initialization via builder config:

let builder = MarketingCloudSDKConfigBuilder()
            .sfmc_setApplicationId(appID)
            .sfmc_setAccessToken(accessToken)
            .sfmc_setMarketingCloudServerUrl(appEndpoint)
            .sfmc_setMid(mid)
            .sfmc_setInboxEnabled(inbox as NSNumber)
            .sfmc_setLocationEnabled(location as NSNumber)
            .sfmc_setAnalyticsEnabled(pushAnalytics as NSNumber)
            .sfmc_build()!

Also based on comments in the LearningApp sample is required register push notifications during app start (we are using SDK version 6.4.2):

// In any case, your application should register for remote notifications *each time* your application
// launches to ensure that the push token used by MobilePush (for silent push) is updated if necessary.

We found special method on iOS which looks like should disable push notifications:

sfmc_pushEnabled

So, can I make sure that InBox will work stable in the following cases:

  1. If iOS is not request permissions to Push Notifications.
  2. If we disable push notification using sfmc_pushEnabled method.
  3. If the user has several devices for 1 Contact.
  4. Push Token is not related to InBox and won't affect sending InBox messages to Contacts.
0
  1. push permissions are not required
  2. yes
  3. yes
  4. true
2
  • Bill, thanks for the answer. I have one more question: 1. Contact has several devices. 2. I'm sending Inbox messages to the Contact - not to the device (based on the documentation). Are the push notifications somehow related to define target device which should be used to deliver InBox messages? – Ilya Apr 9 '20 at 7:11
  • I don't understand your question. Please ask a new question and provide details around what you're trying vs. what is happening. – Bill Mote Apr 9 '20 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.