0

You can authorise an org in sfdx via this command

sfdx force:auth:web:login -r https://customer1customdomain.lightning.force.com -a customer1

When the org is SSO-enabled, I can only login by bypassing SSO by appending ?login to the URL:

https://customer1customdomain.lightning.force.com?login

However, I can't seem to make it authenticate the sfdx connected app.

How do you authorise sfdx in a SSO-enabled org?

  • what happens? It works fine for me if I use the following url https://domainname.my.salesforce.com. It opens a browser up which authenticates with SSO and says "successfully authorized" in the terminal – Kris Goncalves Apr 1 at 17:35
0

Try setting the instance URL in your auth call:

sfdx force:auth:web:login --setalias my-hub-org --instanceurl <your domain here>

You may also be able to configure a connected app to handle the additional auth requirements as seen here: https://developer.salesforce.com/docs/atlas.en-us.sfdx_dev.meta/sfdx_dev/sfdx_dev_auth_connected_app.htm

and referenced here: https://developer.salesforce.com/docs/atlas.en-us.sfdx_dev.meta/sfdx_dev/sfdx_dev_auth_web_flow.htm

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.