0

I'm encountering an issue while trying to save a file in VSCode in a project with manifest. It is not a sfdx project.

While pushing to org, I randomly get this error since a few days now :

Starting SFDX: Deploy Source to Org

11:32:39.799 sfdx force:source:deploy --sourcepath /Users/julien/Developer/Salesforce/VS/360 Dev 3/force-app/main/default/classes/OrganisationsSelector.cls --json --loglevel fatal
The deploy is still in the Queue
11:32:53.266 sfdx force:source:deploy --sourcepath /Users/julien/Developer/Salesforce/VS/360 Dev 3/force-app/main/default/classes/OrganisationsSelector.cls --json --loglevel fatal ended with exit code 1

The deployment fails for no reason. I looked for the message "The deploy is still in the Queue" in Google but I just found that pull request and the message seems to be associated with the "beta_tapi_queue_status" label which I don't know what it is.

I don't know what to do, as it is completely random.

Here is some detail on the versions :

~ sfdx version
sfdx-cli/7.52.0-c5ad5c3eff darwin-x64 node-v10.15.3

and

~ sfdx plugins --core
@oclif/plugin-autocomplete 0.1.5 (core)
@oclif/plugin-commands 1.2.3 (core)
@oclif/plugin-help 2.2.3 (core)
@oclif/plugin-not-found 1.2.3 (core)
@oclif/plugin-plugins 1.7.9 (core)
@oclif/plugin-update 1.3.9 (core)
@oclif/plugin-warn-if-update-available 1.7.0 (core)
@oclif/plugin-which 1.0.3 (core)
@salesforce/sfdx-trust 3.0.7 (core)
analytics 1.7.1 (core)
generator 1.1.2 (core)
salesforcedx 48.7.1 (core)
├─ @salesforce/sfdx-plugin-lwc-test 0.1.5 (core)
├─ salesforcedx-templates 48.7.0 (core)
└─ salesforce-alm 48.8.0 (core)

I eventually manage to save the file but only after multiple tries (1 to 5 or 6 times in average). Just imagine the wasted time here, it is starting to get me crazy.

I already tried to completely uninstall and reinstall everything, but with no luck.

EDIT : it only happens on apex files, I do not have the issue on lwc files at the moment.

Thanks for any ideas !

1
  • 1
    I just disabled the "Experimental: Deploy Retrieve" option in the Salesforce Feature Preview section ("salesforcedx-vscode-core.experimental.deployRetrieve": false). It looks like the issue's gone. I'll keep you posted in the next hours. Commented Mar 30, 2020 at 12:56

1 Answer 1

1

People, that was it : the "Experimental: Deploy Retrieve" option is not ready to be enabled.

Just go to your Settings, and uncheck that option :

enter image description here

Or go to the JSON version of your settings and set

"salesforcedx-vscode-core.experimental.deployRetrieve": false

Hope it helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .