7

I have a custom object "BD lead" . When I try to make a report for this object, I am not able to find this object in report builder.

11

When you create a custom object in salesforce. You have check for a check box in Optional Features -->Allow Reports. So please try doing that.

  • My flag is showing checked but my object is still not showing..Any suggestions? – user24034 Aug 18 '15 at 21:16
7
  • Go Back to your object Setup > Create > Your_Object
  • Click on Edit
  • At the bottom under Optional Features, check Allow Reports and Save it

Also a kind of possible problem is after creating the report type, some fields are missing in the report builder. This is because of custom fields have not been added to the report type.
To resolve this,

  • Go to Setup > Create > Report Types.
  • Click on your Custom Report Type.
  • At the bottom under Fields Available for Reports click Edit Layout.
  • Then drag and drop the fields you want to display on report from right hand side panel and save it.
3

Good amount of details, power of community!!! great to see, still just thought of adding this picture !

enter image description here

0

I got into the same situation & found that if you expand other reports folder (Last folder ), you'll be able to find your custom object.

Hope this may help!

Thanks, Dhrumil

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.