1

I'm tried to import Accounts into an instance with Country Picklists enabled and running into issues.

If the country of the record is not the country set as Default in SFDC State and Country Picklist setting, it doesn't recognize the Country code Qand the record inserts fail.

Anyone else experience the same problem?

-Quade

  • Which import tool are you using? And please identify the column value : specific Account field name. – cropredy Mar 12 '14 at 21:13
  • Hi crop, I'm using Jitterbit , the free version. I'm updating both BillingCountry and ShippingCountry. Thanks – Quade Mar 13 '14 at 12:41
  • Why would you be using a default country? – Michael Rebak Apr 13 '15 at 10:51
3

I tried out Jitterbit 5.0.3.8 on my sandbox instance which has state and country picklists enabled

With no default country enabled

Test data was two rows - One specifying BillingCountry as Denmark, the other as DK.

enter image description here enter image description here enter image description here enter image description here

As you can see, the row that mapped DK to BillingCountry failed as expected. Jitterbit (free) won't let you map to BillingCountryCode as far as I can see; In fact, you can't even query on the column BillingCountryCode (!)

I repeated the test with a default country = Argentina

Results exactly the same as above

Now, I changed the Integration Value (thanks @Carolyn) to DK from Denmark

enter image description here

In this case, the row mapping 'Denmark' to BillingCountry fails but the row mapping 'DK' to BillingCountry succeeds.

However, with DataLoader (I used V30), you can map ISO country codes to BillingCountryCode.

This input worked fine and created valid Denmark Accounts in both cases:

enter image description here

enter image description here

  • "I can only conclude that, in Jitterbit, you need to map the country name, not country code to BillingCountry." Close! The value in BillingCountry needs to match a country integration value. By default, these are the same as the master label, but they can be changed to anything. OP might want to change them to the code values, to match their data. – Carolyn Grabill Mar 13 '14 at 18:10
  • Thanks @Carolyn, I updated the answer - I had forgotten about the Integration Value – cropredy Mar 13 '14 at 18:21
  • Hi crop, So the solution is as simple as setting the default country to None during the migration! Thanks so much :) – Quade Mar 13 '14 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.