2

I have an approval step criterium that records below €5,55 should be approved automatically. I can't get it to work.

I tried setting the step to "greater than 5,55, else approve". However the comma is interpreted wrong, I think the step compares the value to 5 and to 55..

greater than 5,55

log

Then I tried setting the step to "greater than 5.55, else approve". However, the dot is filtered out because it is a thousands separator in the euro-currency.

greater than 5.55

log

Am I correct to state that this is a bug? And if so, how do I report it to Salesforce?

2 Answers 2

2

Hmm looks like a bug indeed. And a dangerous one. Reporting to SF can be done by opening a Case with SF support. Bear in mind that you will have to provide them with inputs to replicate it.

Does this occur only when running the approval process as a dutch user or also when running it as an English user?

I don't know if you need assistance with solving the issue, but if you do: To be on the safe side, I'd advice creating a Boolean formula field that evaluates the amount, and use that formula field in the workflow..

3
  • I tried editing the step when in English mode, then reverting to Dutch. It didn't help. Mar 12, 2014 at 18:50
  • I sse. But I would be curious to see if it also goes wrong if you stay in English mode. That will influence the severity of the issue (and thus the priority at which SF will pick it up) since the largest customer base is English.. Mar 12, 2014 at 19:43
  • As long as I'm in English mode it works just fine. You can easily check it yourself in a Developer Org. Create an approval process with decimals, and play with the Language settings. Have fun ;-) Mar 13, 2014 at 11:36
0

As a workaround, change your approval process filter to a 'formula evaluates to true' and multiply the bedrag field by 100 and compare against 555 - this will avoid the decimal place/locale issue altogether

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .