3

In a scratch org, I foolishly removed the "System Administrator" profile from the Members Selected Profiles of a Community and now the "Workspaces" and "Builder" links are no longer available. That means I can't just re-add the "System Administrator" profile. And when I try to push code in (for use by a second Community instance) using SFDX I get this sort of error:

Error force-app/main/default/contentassets/logo.asset We can't install the package because you're not a member of the community Portal. To install it, first add yourself to the community.

Is there any way out of this? I can create a new scratch org, but wonder about this happening in production and so leaving a production Community in a bad state.

  • Have you tried pushing in access for the System Admin within the NetworksMemberGroups in the networks metadata type? Or do you get the same error message? – Kris Goncalves Mar 26 at 14:01
  • My approach: create a new scratch org :) – Phil W Mar 26 at 14:03
  • I've kicked off another scratch org setup... – Keith C Mar 26 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.