0

I am new to VSCode and and trying to switch from Eclipse and this is becoming already painful.My end goal is to reconnect an existing project I already created with an existing Sandbox. I already created the project and did some work. Then I had to witch to another org and I created a new project, but now I need to switch back to my original Project and Org. So What I did is in VSCode I selected File - Open Folder, and selected my project. But now I need to authorize. When I hit Ctrl+Shift+P and type sfdx, I do not see the sfdx Authorize Org. What am I missing?

7
  • Are you sure you have the sfdx-cli and sfdx VS Code extension installed correctly? Can you post a screenshot of the successful installation of both please so we can help you better? Mar 25 '20 at 15:54
  • Yes, I do. I was able to create 3 project from scratch for 3 different sandboxes with no problems. But, now I am trying to go back to my 1st project and I can not.
    – Ivo Dimov
    Mar 25 '20 at 15:57
  • try to run some other command related to sfdx. It will start activating the extensions. Once the sfdx extension got activated, You will get option to set the default org Mar 25 '20 at 15:57
  • 1
    Make sure you have the correct folder open. It must be exactly in the folder you open, not any sub-folder. It's an easy mistake to make.
    – sfdcfox
    Mar 25 '20 at 16:03
  • 1
    One easy way to tell is to press Ctrl/Cmd-Shift-C (Open New Terminal) and then ls -la or dir. You should see sfdx-project.json listed here. If not, you've got the wrong folder open.
    – sfdcfox
    Mar 25 '20 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.