2

While trying to deploy TopicsForObjects in the packaging org I receive the following Error:

Error metadata/package.xml package.xml You cannot install or upgrade a package that has a TopicsForObjects component. Remove components of TopicsForObjects type from the package.

The Topics have been enabled in Salesforce Classic and are enabled on a Custom Object.

The deploy is done via those two commands and after the second one the Error occurs:

  1. sfdx force:source:convert
  2. sfdx force:mdapi:deploy

Maybe it's not possible to deploy Settings from Salesforce Classic to a Lightning Experience App or why is the Error thrown here?

2

Following answer came from the SF-Support:

I have had a discussion with the internal teams here. Based on what we checked, It seems that the error you are seeing is expected since the topicsForSobject is not available under the documentation.

https://developer.salesforce.com/docs/atlas.en-us.packagingGuide.meta/packagingGuide/packaging_packageable_components.htm

That is the reason we were seeing the error to remove the component.

The workaround which you are following as of now should be a viable soln until we have this under the allowed list. I did indeed check for any roadmap / ETA of this being available however, we did not find any information regarding the same.

The mentioned Workaround is to delete that topicsForObjects.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.